Privacy Policy and Terms & Conditions

Direct link to Privacy Policy Click Here

Direct Link to Terms and Conditions Click Here

The PCI Security Standards Council (PCI-SSC) has made a recent decision to disallow the use of the SHA-1 digital signature in a PCI compliant environment. In order to continue operating as a PCI-DSS compliant service provider, Spectra is now required to immediately upgrade our SSL certificates to the newer SHA-2 digital signature. Spectra will begin rolling out the upgraded certificates to all secure web services on November 19th, and should be completed by months end.

Potential Client Impact: Users with older unsupported browsers, and specific older Android devices (v1.0, 1.1, 1.5, 1.6, 2.0, 2.1, 2.2-2.2.3), will be unable to complete a transaction and may have other issues when trying to access eVenue or the other Spectra web-based systems. Please note that this will not affect users with browser versions currently supported by Spectra. Additionally, the only remedy for this issue is for users to upgrade to a currently supported browser version.

Browser Support: Spectra currently supports the most-recent versions of the following browsers for eVenue:

  • Google Chrome
  • Internet Explorer
  • Safari (Mac)
  • Firefox

Note: Users of unsupported browsers who have problems with Spectra sites must upgrade to a current, supported browser version.

Please visit the Product Bulletin page of the (PSO) for an in-depth overview of the SSL Certificate Upgrade.